【更新】VCCWで新規追加の際失敗すると思ったら電光石火のアップデートで快適に使えるようになった 😍

VCCWの作者の宮さんのおかげでVCCWはv3.3.0へアップデート!!
squizlabs/php_codesnifferのバージョンを2.9固定?にして無事vagrant upでエラーなしとなりました 😀

本当にありがとうございます!!!!!!!

  • Vagrant 1.9.5
  • VirtualBox バージョン 5.1.22 r115126 (Qt5.6.2)

の構成で、新規にサイトを作成する際、TASK [Install Composer libraries]のタスク部分で、以下のメッセージが出た 😵

...ignoring
failed: [vccw3.dev] (item=wp-coding-standards/wpcs:*) => {"failed": true, "item": "wp-coding-standards/wpcs:*", "msg": "./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. Problem 1 - Conclusion: remove squizlabs/php_codesniffer 3.0.0 - Conclusion: don't install squizlabs/php_codesniffer 3.0.0 - wp-coding-standards/wpcs 0.3.0 requires squizlabs/php_codesniffer ~2.0 -> satisfiable by squizlabs/php_codesniffer[2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.4.0 requires squizlabs/php_codesniffer ~2.0 -> satisfiable by squizlabs/php_codesniffer[2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.5.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.6.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.7.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.7.1 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.8.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.9.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.10.0 requires squizlabs/php_codesniffer ^2.6 -> satisfiable by squizlabs/php_codesniffer[2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1]. - wp-coding-standards/wpcs 0.11.0 requires squizlabs/php_codesniffer ^2.8.1 -> satisfiable by squizlabs/php_codesniffer[2.8.1, 2.9.0, 2.9.1]. - Can only install one of: squizlabs/php_codesniffer[2.0.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.1.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.2.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.3.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.3.1, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.3.2, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.3.3, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.3.4, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.4.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.5.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.5.1, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.6.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.6.1, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.6.2, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.7.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.7.1, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.8.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.8.1, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.9.0, 3.0.0]. - Can only install one of: squizlabs/php_codesniffer[2.9.1, 3.0.0]. - Installation request for squizlabs/php_codesniffer (locked at 3.0.0, required as *) -> satisfiable by squizlabs/php_codesniffer[3.0.0]. - Installation request for wp-coding-standards/wpcs * -> satisfiable by wp-coding-standards/wpcs[0.10.0, 0.11.0, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.7.0, 0.7.1, 0.8.0, 0.9.0]. Installation failed, reverting ./composer.json to its original content.", "stdout": "./composer.json has been updated\nLoading composer repositories with package information\nUpdating dependencies (including require-dev)\nYour requirements could not be resolved to an installable set of packages.\n\n  Problem 1\n    - Conclusion: remove squizlabs/php_codesniffer 3.0.0\n    - Conclusion: don't install squizlabs/php_codesniffer 3.0.0\n    - wp-coding-standards/wpcs 0.3.0 requires squizlabs/php_codesniffer ~2.0 -> satisfiable by squizlabs/php_codesniffer[2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.4.0 requires squizlabs/php_codesniffer ~2.0 -> satisfiable by squizlabs/php_codesniffer[2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.5.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.6.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.7.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.7.1 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.8.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.9.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.10.0 requires squizlabs/php_codesniffer ^2.6 -> satisfiable by squizlabs/php_codesniffer[2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].\n    - wp-coding-standards/wpcs 0.11.0 requires squizlabs/php_codesniffer ^2.8.1 -> satisfiable by squizlabs/php_codesniffer[2.8.1, 2.9.0, 2.9.1].\n    - Can only install one of: squizlabs/php_codesniffer[2.0.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.1.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.2.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.3.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.3.1, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.3.2, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.3.3, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.3.4, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.4.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.5.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.5.1, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.6.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.6.1, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.6.2, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.7.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.7.1, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.8.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.8.1, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.9.0, 3.0.0].\n    - Can only install one of: squizlabs/php_codesniffer[2.9.1, 3.0.0].\n    - Installation request for squizlabs/php_codesniffer (locked at 3.0.0, required as *) -> satisfiable by squizlabs/php_codesniffer[3.0.0].\n    - Installation request for wp-coding-standards/wpcs * -> satisfiable by wp-coding-standards/wpcs[0.10.0, 0.11.0, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.7.0, 0.7.1, 0.8.0, 0.9.0].\n\n\nInstallation failed, reverting ./composer.json to its original content.\n", "stdout_lines": ["./composer.json has been updated", "Loading composer repositories with package information", "Updating dependencies (including require-dev)", "Your requirements could not be resolved to an installable set of packages.", "", "  Problem 1", "    - Conclusion: remove squizlabs/php_codesniffer 3.0.0", "    - Conclusion: don't install squizlabs/php_codesniffer 3.0.0", "    - wp-coding-standards/wpcs 0.3.0 requires squizlabs/php_codesniffer ~2.0 -> satisfiable by squizlabs/php_codesniffer[2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.4.0 requires squizlabs/php_codesniffer ~2.0 -> satisfiable by squizlabs/php_codesniffer[2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.5.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.6.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.7.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.7.1 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.8.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.9.0 requires squizlabs/php_codesniffer ~2.2 -> satisfiable by squizlabs/php_codesniffer[2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.10.0 requires squizlabs/php_codesniffer ^2.6 -> satisfiable by squizlabs/php_codesniffer[2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.9.0, 2.9.1].", "    - wp-coding-standards/wpcs 0.11.0 requires squizlabs/php_codesniffer ^2.8.1 -> satisfiable by squizlabs/php_codesniffer[2.8.1, 2.9.0, 2.9.1].", "    - Can only install one of: squizlabs/php_codesniffer[2.0.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.1.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.2.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.3.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.3.1, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.3.2, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.3.3, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.3.4, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.4.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.5.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.5.1, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.6.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.6.1, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.6.2, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.7.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.7.1, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.8.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.8.1, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.9.0, 3.0.0].", "    - Can only install one of: squizlabs/php_codesniffer[2.9.1, 3.0.0].", "    - Installation request for squizlabs/php_codesniffer (locked at 3.0.0, required as *) -> satisfiable by squizlabs/php_codesniffer[3.0.0].", "    - Installation request for wp-coding-standards/wpcs * -> satisfiable by wp-coding-standards/wpcs[0.10.0, 0.11.0, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.7.0, 0.7.1, 0.8.0, 0.9.0].", "", "", "Installation failed, reverting ./composer.json to its original content."]}

…長いっすね。。。
更に、TASK [Install Ruby gems]でも

changed: [vccw3.dev] => (item=bundler)
...ignoring
failed: [vccw3.dev] (item=wordmove) => {"cmd": "/usr/bin/gem install --version 2.0.2 --user-install --no-document wordmove", "failed": true, "item": "wordmove", "msg": "WARNING:  You don't have /home/vagrant/.gem/ruby/2.3.0/bin in your PATH,\n\t  gem executables will not run.\nERROR:  Error installing wordmove:\n\tphotocopier requires Ruby version ~> 2.4.", "rc": 1, "stderr": "WARNING:  You don't have /home/vagrant/.gem/ruby/2.3.0/bin in your PATH,\n\t  gem executables will not run.\nERROR:  Error installing wordmove:\n\tphotocopier requires Ruby version ~> 2.4.\n", "stdout": "Successfully installed colorize-0.8.1\nSuccessfully installed thor-0.19.4\nSuccessfully installed i18n-0.8.1\nSuccessfully installed thread_safe-0.3.6\nSuccessfully installed tzinfo-1.2.3\nSuccessfully installed concurrent-ruby-1.0.5\nSuccessfully installed activesupport-5.1.1\nSuccessfully installed net-ssh-4.1.0\nSuccessfully installed net-scp-1.2.1\nSuccessfully installed net-ssh-gateway-2.0.0\n", "stdout_lines": ["Successfully installed colorize-0.8.1", "Successfully installed thor-0.19.4", "Successfully installed i18n-0.8.1", "Successfully installed thread_safe-0.3.6", "Successfully installed tzinfo-1.2.3", "Successfully installed concurrent-ruby-1.0.5", "Successfully installed activesupport-5.1.1", "Successfully installed net-ssh-4.1.0", "Successfully installed net-scp-1.2.1", "Successfully installed net-ssh-gateway-2.0.0"]}

っと…😵

一先ず、WordMoveは動くようになった

“Error installing wordmove:tphotocopier requires Ruby version ~> 2.4.”って言っているので、vagrant sshでログイン後、

sudo apt-add-repository ppa:brightbox/ruby-ng
sudo apt-get update
sudo apt-get install ruby2.4 ruby2.4-dev
ruby2.4 -v

とした後、ログアウトし、”vagrant provision”で、WordMoveちゃんと入った 😀

TASK [Install Composer libraries]の方は、

WordPress-Coding-Standards/WordPress-Coding-Standards: PHP_CodeSniffer rules (sniffs) to enforce WordPress coding conventions

Requirements

The WordPress Coding Standards require PHP 5.2 or higher and the PHP_CodeSniffer version 2.9.0 or higher. The WordPress Coding Standards are currently not compatible with the upcoming PHPCS 3 release.

ってあるから、それが原因かなぁと思っているところ。

provision後はWordMove使えてるから一先ず作業はできる。
rubyをインストールする部分のコードを読んで、2.4が入るようになればいいのかなぁ…。

phpcsの方は、金曜日作ったローカル環境が、

  • PHP_CodeSniffer version 3.0.0 (stable) by Squiz (http://www.squiz.net)

コケずにスムーズに作成されていたときのバージョンが、

  • PHP_CodeSniffer version 2.7.1 (stable) by Squiz (http://www.squiz.net)

ってことで、vccwを作成する際に3.0.0以下のバージョンを指定するか、site.yml内でコメントアウトするか悩み中……。

rubyも2.4指定でvccw内にインストールできるのか調べなきゃだ 😅

参考

【Vagrant】Your VM has become “inaccessible.” って言われたら…

vagrant upした時に、

Your VM has become "inaccessible." Unfortunately, this is a critical error with VirtualBox that Vagrant can not cleanly recover from. Please open VirtualBox and clear out your inaccessible virtual machines or find a way to fix.

って言われっちゃったのでメモ。
どうやら、vagrant destroyしないでVirtualBoxから直接削除してしまったか、何かの原因かで、.vagrant というディレクトリが作られるとこのメッセージが出るみたい。

単純にこの.vagrantディレクトリを削除すると、vagrant upできる。
ただし、新たにVMboxを作るのでもしも、自分でVMを削除した記憶がない時はこれらの作業で新たにVMが作成されるので、注意。

気がついたら、ディスクがVMで一杯でした…なんてことになりかねない ^^;

※ 一度VirtualBox内のVMを全部削除して、新たに作り直すのもありと宮内さんに教えてもらった、あざます!! 😀

参考URL

brew doctor エラーメモ

brew doctorでエラー出てた。

brew doctor
Error: Failed to import: abstract-php
formulae require at least a URL
Your system is ready to brew.

で、brew readallやってみたら

brew readall
Error: problem in /usr/local/Library/Formula/abstract-php.rb
No available formula for abstract-php 

で、brew tap –repairやってみると、

brew tap --repair
Pruned 1 dead formula
Tapped 453 formulae

“Pruned 1 dead formula”って出てて、このあとbrew doctorすると、

brew doctor
Your system is ready to brew.

良かった 😀

参考URL

php formula missing? · Issue #1034 · Homebrew/homebrew-php

500エラー出たと思ったら、PHPが4だった。。

ヘテムルにあるWordPressなサイトが500出てると連絡を受けて、確認してみたところ、サイトはおろか、ログインも何もできない状態になってた。

.htaccessを外してみると、

サーバーの PHP バージョンは 4.4.4 ですが WordPress 3.6.1 は 5.2.4 以上のみでご利用になれます。

と出てきた。.htaccessを上書きか何かされたのか、元々このヘテムルアカウントはPHPのデフォルトバージョンが4だった。
以下を参考に.htaccessへ

AddHandler php5.4-script .php

を追記。するとデータベース接続でもエラー出たので、
PHP5.4の提供を開始いたしました – ヘテムルレンタルサーバー の

現在PHP5.4から接続ができないMySQLには「要設定」のリンクが表示されておりますので、
一度パスワードの変更を行なっていただくことでPHP5.4からの接続が可能となります。

※パスワードは現在設定されているパスワードと同じもので変更いただいても問題ありません。

を参考にコンパネからDBパスワードを変更。といっても元のまま。単に元のパスワードを入力して変更をクリックするだけ。

これで管理画面へログインできるようになった。
後は、順次プラグインやテーマを更新して、コアを3.9へアップグレード。

サイトも表示速くなった感じ 😀

参考サイト(ありがとうございます!!)